Privacy Policy Welcome to Age of Empires Online
in Search

Launcher not working

Last post 08-23-2012, 6:52 PM by BarbarossaBlade. 10 replies.
Sort Posts: Previous Next
  •  08-22-2012, 10:34 AM 270124

    Launcher not working

    Hello,

     

    2 days ago I could launch the game without any trouble, all worked fine. Today I decided to play more but this happened:

    When the launcher was ready with patching, I clicked "play" but nothing happened (launcher said: game has been launched). After few seconds the launcher closes as well. I tried run it as administrator, no succes. Reinstalling didn't help either and  Verify files on steam didn't work either.

    I've no clue what I can do to fix this, and hope someone around here is able to help me. Here's the patchlog:

     

    012888 | Core initialization complete.  Attempting to load launcher dlls and begin patch process.

    012888 | The file "D:\Games\Steam\steamapps\common\Age Of Empires Online\AoeOnlineDlg.dll" is signed and the signature was verified.


    012888 | Loaded LauncherUI DLL from [D:\Games\Steam\steamapps\common\Age Of Empires Online]

    012888 | Loading dll from UserLocal folder.

    012888 | The file "D:\Games\Steam\steamapps\common\Age Of Empires Online\AoeOnlinePatch.dll" is signed and the signature was verified.


    012888 | Loaded Launcher DLL from [D:\Games\Steam\steamapps\common\Age Of Empires Online]

    012888 | Loaded and initialized dlls, attempting patch.

    012888 | Beginning patch process.

    000000 | Starting patch process

    000000 | Version 6.0

    000000 | LauncherLocList.txt is loaded and valid

    000000 | Language in user registry is [en-US]

    000000 | Locale in user registry is [1033]

    000000 | Setting new state [2]

    000000 | New state set [WaitingOnDirectoryInformation]

    000000 | Setting new state Devil

    000000 | New state set [WaitingOnManifest]

    000001 | Setting new state [28]

    000001 | New state set [DownloadPDLCFiles]

    000001 | Setting new state [15]

    000001 | New state set [Complete]

    000002 | Setting new state [16]

    000002 | New state set [GameLaunched]

    000053 | Setting new state [23]

    000053 | New state set [ShuttingDown]

    000053 | Shut down requested

    000053 | Updating user registry [en-US] [1033]

    012941 | Waiting for patcher thread to signal finish

    012941 | Waiting for Patcher thread to exit.

    012941 | Patcher thread successfully shut down.

    012941 | Play/patch loop exited.  Exit code:  0x00000000 UI exit code 0x00000000

     

     

    Thanks in advance 

     

  •  08-23-2012, 12:47 PM 271108 in reply to 270124

    Re: Launcher not working

    Based on the logs here, it looks like the game was running for about a full minute before getting the shutdown command.  Are you sure you didn't accidentally close the launcher?
  •  08-23-2012, 5:04 PM 271434 in reply to 271108

    Re: Launcher not working

    No, I didn't close anything.

    The launcher stays on my desktop for 1 minute, and then closes himself.

    When I verify my gamecache, it says 7 files are not validated and are being reinstalled.

    After that, I start game again and have the same result. When I repeat the varify gamecache, it says again 7 files are...

    I've no clue what is causing this :| 

  •  08-23-2012, 5:08 PM 271442 in reply to 271434

    Re: Launcher not working

    It sounds like Steam may not be delivering the files correctly.  Do you see any indication that the files are being downloaded? You should see a progress bar at the bottom of the Steam client, or select Downloads on the dropdown on the Library section.
  •  08-23-2012, 5:19 PM 271458 in reply to 271442

    Re: Launcher not working

    I am having this exact same issue. Using steam, when I scan my game cache it says 7 files are corrupt. I download them and I still cannot get into game. If I do get into game, my mailboxes don't work and I quickly get disconnected.
  •  08-23-2012, 5:23 PM 271461 in reply to 270124

    Re: Launcher not working

    Same issue here.
  •  08-23-2012, 5:31 PM 271477 in reply to 271461

    Re: Launcher not working

    Here is a link to a screencap of the Steam download dialog after I downloaded the 7 files.

    http://imgur.com/PRoBw 

  •  08-23-2012, 5:34 PM 271479 in reply to 271477

    Re: Launcher not working

    Grr... put an extra space in the hyperlink.

     http://imgur.com/PRoBw

  •  08-23-2012, 5:59 PM 271513 in reply to 271479

    Re: Launcher not working

    I'm going to try download the game from the AoE site itself. Perhaps it's steam not downloading correctly but I do get a download bar when reinstalling those 7 files.
  •  08-23-2012, 6:05 PM 271518 in reply to 271513

    Re: Launcher not working

    never mind, reinstalling didn't help at all. 
  •  08-23-2012, 6:52 PM 271574 in reply to 271479

    Re: Launcher not working

    Hi Centuri,

    It sounds like you are able to load the game, which would make this a different issue.  Let's start a new thread for that.

View as RSS news feed in XML